Eclipse gets unusable after upgrade to 2018-12.

When opening any kind of file, I constantly get this message popping up.

error message

After searching the web and finding loads of totally stupid suggestions on how to fix this, I stumbled upon this issue, which got me on the right track.

I had XIM configured as input method, which apparently does not work well with Eclipse.

So, either do not use XIM or lauch Eclipse via a script and unset GTK_IM_MODULE or export GTK_IM_MODULE=ibus.